Sevcon size4 ME1616 motor not rotating make only noice


1 µW
Sep 30, 2019
I need help with Sevcon gen4 size 4. I replaced kelly with sevcon but I can't get it to work. I got dcf from motenergy but it is for size 6 controller and I got some notifications about software version incompability.

I managet to make all settings and connections and everything seems to be ok.

But the motor is not spinning and it only makes noice when pressing acceleration pedal.

Motor I use is ME1616 (same as 1507 but with watercooling)
If someone has working dcf for size 4 and ME1616 it would be most helpful

Can someone help?


(I am sorry if this post overlaps with some previous discussion. But I wasn't able to find help from those.)
I don't have much experience with programming sevcons but a few things to look into:
-rotary encoder calibration
-any differences between the water cooled version, simpler, dumber controllers wouldn't care, but a few uH either direction and it can make a difference
- Are all the connections identical from the reference program (phase wires, sensor /etc) are they all in the appropraite sequence?
I read the post containing the encoder calibration but I found it to be really difficult to understand. I didn't manage to get it calibrated. If someone can help with this would appreciate alot!

The uH in current dcf and in some information what I found from this forum is different. I may try with value I found from this forum.

I don't know. But I only have one option for motor lead arrangment since in all other conficurations I run out of wire. So basicly I would prefer this to work in current order.

I tried to change sin and cos from one to other but it made no diference.
Aren't there any experts available willing to help with these even on a paid basis?
I have the same problem as stated with the only difference that I have the Gen4 Size6 with the same motor(me1616).
I would apreciate any help. I tried out so many things for days now. Set all back to original state. The Gen4 came with actual software and firmware and dfc for the me1616. But the only thing that happens is some noice when i turn the throttle...
No errors, contactor clicks, analog input is okay(throttle), I/O set and active(FS1, ForwardSwitch, SeatSwitch).
Now I turn the throttle the motor seems to vibrate very little, nearly unnoticable but with a noice(not too loud, as if it wanted to try to turn.)
I have a power supply with 80V and 50A attached to the controller.
Did you ever get your motor working? I am having the same issue with a ME1507. I am a newbie as well. I have the DVT software and I was given an example DCF file from Motenergy but it isn't working. I have no errors, contactor clicks, I am seeing throttle values in the software. Where do I start in troubleshooting the motor configuration?



  • 2021-02-12a-RZR.dcf.txt
    585.4 KB · Views: 64
  • Gen4-pmac-sine-cosine wiring.pdf
    202.4 KB · Views: 86
I got my bench test running. I had to swap the cos and sin wires which means I ended up reversed to the suggested wiring diagrams. I sent an email to the motor manufacturer asking them why mine is backwards in hopes to better understand my ME1507 motor.

I also tried switching the phase wires but it didn't help. Swapping the sense wires is what did the trick.

I was having similar issues with my Sevcon gen4size6 with ME1616. My solution was to change encoder pin C (0 V) from Sevcon pin 15, to B-. In other words, instead of connecting encoder pin C (0 V) to Sevcon pin 15, per instruction manual, I have it connected directly to Bat- (common ground). I did this because I was not getting 5V b/w sevcon pins 26 and 15 (more like 1 V), but I was getting ~5.4 V between 26 and Bat-.

My root cause analysis went as follows:
1. upload DCF from John at Motenergy
2. update various settings to suit my setup (contactor voltage, battery limits, motor limits, etc)
3. fix all the faults (I was getting many range errors, the "Find Range Errors" button on DVT helps a lot)
4. Motor was making noise, but not spinning
5. Directly checked that the encoder was functional with a voltmeter. Yes it is good, getting ~2 to 4 V per mechanical rotation on the Sin and Cos outputs from encoder
6. Bang my head against the wall and try a bunch of useless things
7. Finally, I checked the voltage between pins 26 and 15 on the sevcon side of the encoder connector (pins E and C on encoder side) and discovered my issue.

I will note that during step 6 of trying a bunch of useless things, I indeed swapped the Sin/Cos pins per bastens_com recommendation. This was not my main issue, but I have not switched it back and it is working. Maybe I had two issues.