Phaserunner v6 and Baserunner v5 oddities


1 µW
Jul 11, 2021
Hello Folks,

This is more of an open discussion rather than a specific troubleshooting topic. I'm looking for others than have had experience with multiple generations of Grin ASI-based controllers to see if anyone else has noticed a change in the newest generation.

Backing up a bit for context. I had been running a Phaserunner V3 for a couple years, initially on a 9C clone and then on a 10T GMAC. This system is running on a 52v EM3EV battery and was rock-solid reliable in all conditions and situations. I had the system typically configured draw a max of 30A from the battery, and had the CA set to limit power to "1500w" and it would get up to those numbers when asked.

I was exceedingly happy with the system, so much so that I ponied up the bucks to outfit my wife's Cattrike 5.5.9 with a PR/GMAC combo. At that time the Baserunner V5 L10's had come out and I was going to be building the battery, so I grabbed a couple Reention DP-6C cases and controllers so this and another project would look clean and neat. Once all the components were in I eagerly got to building, and upon completion was..... immediately disappointed.

My wife had an accident 15 years ago that smashed her lower leg, and it's now full of metal parts. While being part cyborg can be interesting, it also means she cannot use that leg for any usable human power, which is why a torque'y motor is critical. She needs power off the line to make this whole thing work, and while my GMAC on the Phaserunner V3 set to 30A and 1500W had more than enough umph to smoothly launch me up to speed this system also set to 30A and 1500W did not. I know the PR and BR-L10's have different phase current limits (96 vs. 70), but this system was putting out less off the line torque than an old Baserunner Z9. It would pulse, buck, and grind from a standstill, slowly start moving, and once up to speed would then have all sorts of torque.

It acted as if it was in sensorless mode, but that was certainly not the case. Putting the system in sensorless mode would produce a very different pulsing, but which was perfectly normal for a sensorless start in my experience. If she had to start on an uphill incline, the system would often buck for a couple seconds and then go into an error state and not produce power until turned off and back on. By contrast my daughter's bike running a Baserunner Z9 on a G311 has far more pulling power off the line running with far less phase amps and at 12A/500w is silky smooth like my Phaserunner V3. No amount of autotuning or tweaking ramping would correct this problem, and as much as I love Grin and their products their support staff often don't respond, and the one time they did to a detailed email it looked like a cut and paste from a script to check if connections were good, which I had already laid out in the email.

Fast forward to this March when I made a boneheaded move and downloaded Phaserunner Suite 1.8.0 and the most recent controller defaults and decided to apply those to my Phaserunner V3. Immediately after that I started getting a couple problems.
First the bike would go into regen speed limiting when the wheel hit 4MPH, while the CA was set to have that kick in at 25. This was mostly corrected by setting the 'Wheel Sp. Sensor Pulses Per Rev' setting (which appears to be new in 1.8.0) to 0 Pulses/Rev where it defaulted to 6.
I was prompted to do this when I noticed in the Phaserunner Suite dashboard that it thought the bike was going 200km/h when the tire was barely spinning. I also started getting the instantaneous phase over-current (error 2.2) events when putting load on the system. Nothing physical changed on the bike or in the system, just loading these new defaults with version 1.8.0.

Now working in tech I should know better than to apply updates without a 'full' backup, and I did not in this case so that V3 is now stuck this way and virtually unusable. Running an autotune after the update would occasionally result in a bad hall pattern detected error during the spin test, prompting me to swap out this GMAC core for a spare I had with the same result. Halls all tested good, phase wires all test good, I was stumped.

I (reluctantly) ended up ordering a new Phaserunner V6 in April to just get this system back to being reliable as I need it for my work. Once that came in and I got it installed and ran into the same problem with my wife's Baserunner-L10 V5, weak on starting, not at all smooth. Loading the motor defaults for the GMAC would cause the instantaneous phase over-current with any load on the wheel, and the autotune would come back with very different Rs and Ls values than what the V3 detected. Putting in the alternate motor core (and subsequently a diffrernt cable) would result in the same thing.

This V6 also will not power the GMAC to the levels I was getting with the V3. When the autotune function is run multiple times it eventually result in settings that would allow the controller to power the motor without the phase overcurrent error, but it also lowers the Nm from 105.2 (GMAC defaults) to 104.2 or occasionally lower which didn't happen on the V3. In use on the road I'm not getting the same acceleration or torque I did with the V3, and the regen went from a strong 500W+ of stopping power to maxing out around 250W. Setting the controller to draw a max of 40A from the battery for testing and setting the CA limit to 2000W would only get me a max of 1440W at full throttle under load where the V3 would actually produce that when it was functional. Nothing I could do would result in this system producing the same power and feel the V3 did.

This last weekend I opted to convert our old RadWagon to a CA3 and the other Baserunner-L10 V5, and its also exhibiting the same behavior as the Cattrike and this Phaserunner V6. Off the line it's incredibly weak and pulsing the Bafang like a jackhammer until it gets some speed. Absolutely no chance of getting it moving on an uphill incline with a child on the back without putting in a couple hundred watts of leg power to get the bike moving for the motor.
The original 15A controller currently is far safer for traffic as it can actually start the vehicle moving at a reasonable pace. Again, no amount of autotuning or tweaking of ramping or feedback seem to help. I've tried limiting and increasing the phase current, adjusting the v/sec for throttle up to smooth it out, nothing helps. Tested the cabling from the motor, and the Z910 to L10 adapter, everything checks out good.

It really 'feels' like something changed starting with the Baserunner V5 / Phaserunner V6 generation, or with the 1.8.0 Phaserunner Suite and it's defaults that could be causing this behavior. It's also possible that I've just ran into a lot of bad luck, so not ruling that out.

So I'm looking for anyone whom may have experience with the old and new controllers to sort out if its just me or not.

As always, thank you for taking the time to read.

(Edited to clean up a bit)
Last edited:
First off, i don't mean to be rude but you could really use some paragraph breaks in your writing, it's extremely hard to read, i had to skim it.

Second, have you contacted grin? their tech support is usually really helpful from what i hear.
Last edited:
Apologies, I'm terrible at writing and typically would avoid posting something publicly because of that. I wouldn't take that as rude, it's a valid observation.

I have emailed their support a number of times in the recent months. Acutally have an email thread where i'm the only one replying to myself as I discovered new things. I'm assuming they just don't have the people power to answer everything that comes in. Also the inherent headaches of trying to support DIY products with customers of various technical (and writing) levels, they have my sympathy.

After scouring this forum for a few weeks I thought I'd reach out to the community to see if anyone else was experienced anything similar. I will reach out to Grin again with an update to include this RadWagon's G60 issue, we're getting into intern season so my chances might be better.

Thank you for the reply @neptronix
Ah, well just practice those paragraph breaks and keep things short :)

I have to be honest i do own a phaserunner but have never tuned it so i can't help you with tuning expertise there.
In infineon clone/programmable square wave controller land, a jerky/funky start is usually a matter of bumping up phase aka 'motor' amps over stock because this strongly affects the power in the lower part of the power band.

In FOC controller land it could be due to a wide range of settings..
What i would do is take a stock grin tune for the GMAC and start adding amps to it.

The baserunner has a lower 'phase amps' capability and i would say anything under 90A phase isn't enough to get the MAC really going, i think on my 8T w/36V i was rocking 120A phase amps.

Another issue - how big is your battery? do you have a cycle analyst and see the voltage drop like a stone when you hit the throttle?

Side note..
I do see some issues on the forum from time to time with the GMAC + phaserunner combination; truthfully it's a motor that is difficult to drive in the first place. For that reason i would start with a modified Grin tune because it might have been semi-rocket science to get the combo working correctly.
FWIW, even though your halls all test ok, everything you're describing sounds like a hall timing or hall/phase combination problem, which can cause "normal" operation when loading is lower, but have all sorts of problems when loading gets high enough...and under the high load, the timing caused phase current to be sent incorrectly, which then causes the controller to detect wrong motor response, which makes it rollback or shutdown output, then restart, which can cause the jackhammering..

It can also be incorrect motor parameters in the FOC settings, causing the phase current to be sent incorrectly, which then causes the controller to detect wrong motor response, which makes it rollback or shutdown output, then restart, which can cause the jackhammering.

It could also be insufficient phase current, but if a smaller generic non-FOC controller can still drive the motor well enough under the same circumstances, that's probably not it.

If it's a hall timing problem, it is usually the wrong phase/hall combination, which the controller might not be autodetecting correctly. I think the PR suite has a page to show you the halls / phases cycling so you can see if they're going in the expected order, but if not you could manually swap phases and halls until they work, if you have individual connectors for each wire. (if not, there's no good way to do that without making an extension cable between them, that you can cut and splice as needed for testing, unless you cut into the controller or motor cable itself, which I don't recommmend unless there isn't any other way.

If it's an FOC setting, I'd start with the default Grin settings for the specific motor you are working with, if they have a setup for it. If they don't, but someone else has used that motor successfully with an *Runner, then use any settings they posted for it, or see if you can contact them to find out what they used.

Then you can tune (very small changes at any one time, to only one setting, taking notes for the setting value and resulting behavior) to see what happens, and if things get better keep going that way until it gets worse and go back. If htings get worse, go the other way, etc. Then go to the next setting, and tune that the same way. Repeat for all the settings, keeping notes for every change.
I'm absorbing all literature and web resources I can find on FOC's in general these days. I agree they are complex, and even systems designed to simplify the tuning process like Grin/ASI's don't get it right all the time. I'm in hopes that it's a problem that a setting can resolve rather than a lot of expensive kit that will come up as another example every time I fail at something :) .

I do believe the batteries involved are all in good working order. I recently had to haul a fully loaded Cisco Catalyst C6506 off a work site in a trailer, easily over 200lbs itself. Started that trip with roughly 2/3rds charge on a 52v 17.5AH battery, climbed around 1100 feet out of a river valley and the battery had 3 'bubbles' left (roughly 49v) on the CA after the 24 mile trip (12 miles unloaded, 12 loaded).

Couple of caveats on that trip:

This was with the Phaserunner V6 and GMAC with the autotune that prevented the phase overcurrent, but couldn't reach full power or regen. Having done a lot of hauling on the V3 with this rig I was familiar with how this should have gone, and the motor in general was warmer than I expected while the ambient was cooler than normal (around 42f, fairly cool). As well as not having the same punch when I personally ran out of steam fighting loose gravel on an uphill and asked it for a bit more.

More critically on that adventure, the lack of strong regen was a real problem. My workhorse is an old TREK steely with rim brakes, which with regen has been incredibly reliable in smoothly stopping with heavy loads. This time I had to use mostly rim brakes, even with the regen phase amps set to 90A, and the battery regen amps at 15A it could only muster -250w avg. +/- 15w.

90% of the time I'm usually running equal human watts to battery watts used, so most of my own use with the V6 this issue isn't a problem as i'm only averaging 140w output over the course of a normal day. The regen stopping power however is still noticeable even in those normal conditions.

Hello Amberwolf, I was in hopes you would pop in.
I was actually wondering if it was possible that the autotune could get the hall to phase order wrong, but I've got enough life experience troubleshooting to know that to have that happen on 4 controllers is unlikely. Not impossible, but very unlikely. I have a couple of L10 extension cables for recumbent builds i'm working on, I can certainly sacrifice one and put spades on phases and JST on the halls, +5, gnd, speed/therm so I can mix things up. I'm also tempted to replace the halls outright on one of the GMAC's since they arent epoxied in place, just to see if that helps.

Thank you both for your sage advice and sharing of your wisdom. It's refreshing to see a lively DIY community with folks willing to take time out of their day to help others.
Last edited:
it doesn't even have to be completely wrong phase/hall order, it can just be wrong timing. An FOC controller can easily advance or retard timing of signals or phase currents; its often expressed as an angle in degrees. Whether this is exposed as a user-setting depends on the controller (Kelly for instance I think just shows you what it detected, and doesn't let you tune this, so if it didn't work right you're stuck).

(and wrong phase/hall combination is actually just timing that is advanced or retarded by the large electrical or physical degrees between hall positions, rather than the small amounts typically seen from poor autodetection).

I doubt the halls on the motors are problematic, it'd be unusual if they haven't been overheated or electrically compromised (like a short in wiring in the motor/controller cable from physical cable damage, etc).

When a motor/controller system operates hotter than it did with another system, with less power available, it also usually points to a timing issue--you see the same thing when you have a wrong phase/hall combo, because the phases are firing in the wrong order or too early or too late for the magnet polarity and position present over the tooth at the time.

Regen current is typically very high momentary currents, so it's expected it'll have problems similar to the loading of high traction moments.
I will also attest to the newer generations of things seemingly not producing expectations. Though to be clear, I have not owned any versions before the latest Frankenrunner and a CA3, but what I can comment on is what seems to me to be a very buggy software suite across all platforms. I tried them all save for the mac os.

My experience is one of using the software suite at home on windows, then riding to work and wanting to change something so I opted for using the android app, which was very hit or miss to even connect properly most times. Beyond that I have had things change from default values with no direction from me, maybe through another setting linked to the other? In any case is resulted in me having to do the utterly painful experience of Grin's customer service...For all the love I have for a Canadian company, this was 100% not up to my expectations. It was painfully slow to hear back from them, as OP said, I plainly put in my initial email what exactly the problem was, and what exactly I have tried thus far, and I as well received a generic response email from someone who had 100% not read my situation, and then it was an absolute battle to get them to tell me what the default setting for the voltage multiplier(and exact steps to change it back, which by the way is proof that it changed itself automatically because there was zero possibility I had done these steps in the first place) was in the frankenrunner so I could use the device without having the over voltage trip when turned on. it took another 4 emails before getting this information, even though I had requested it exactly in the very first email I sent regarding the issue. I mean, cmon, why make it so hard, it was worse than conversing with a Chinese company (I got less than the clockwork 1 email per day from china and Grins office is one province over). Absolutely unacceptable IMHO.

I could only come to the conclusion that by using all 3 software suites, something somewhere was really doing weird things with defaults or when saving and loading profiles, I am not sure totally, all I can say is there was nothing that ever worked the same or reliably with them, as OP said, auto tunes throwing out totally different numbers, spin up not working 1 second but reloading on another suite with the exact same settings would magically make it work. Underperforming settings with no clear indication of how to tweak the settings unless you have direct knowledge into the tech...I mean, I'm no genius, but this is the first tech hardware I haven't been able to intuitively learn because there is no rhyme to reason a lot of times, unless you have deep knowledge of the hardware, and the information you can find spattered here and there around the net is spotty at best, usually doesn't apply directly to your motor or issue, but there's just not a lot of documentation that I could find specifying steps to take or settings to change or even HOW to change some settings or the implications of changing one settings that has a direct link to something else so change the one and another changes in the background but never changes back. Its been out for long enough to have this type of documentation available in some form, however my first guess is that ASI prevents them from doing such a document for the masses, because from what I have read ASI is not a very people friendly company, which at the end of the day makes no sense, and comes across as them being selfish and having zero care about their customers, willing to directly hurt them after their support of buying the hardware. (Though don't listen to me, as I know very little, but read enough to form this opinion for myself)

Moving on to expectations on the actual hardware. Either I am misreading a whole lot of people all over the internet, and they are making some deepfake videos, or there is something with the newer hardware absolutely NOT being the same power/torque levels as when I first started hearing about how awesome the phaserunner is for bafang motors and how I would be knocked off my feet and never look back or regret the purchase. Well long story short, I am not overly impressed by any means, There is no torque that instantly wants to lift the front tire without some heavy throttle control, the only part I am impressed with is top end speed and a feature I really honestly think is harmful to the motor the more I think about it, (field weakening) Though this is pure speculation as I have no supporting knowledge otherwise, just using some logic and common sense? Either way that's a different discussion.

Little back info here, I was using a CA3 with the stock controller for my Bafang m620 (g510) motor, and was having a really big issue with the software versions as they related to the Frankenrunner settings, and would get wildly different outcomes in performance/ usability by even changing the CA3 firmware by 2 iterations. Sometimes usable, sometimes completely not. This was SO frustrating, putting it lightly. just when one thing worked, Id find out oh this version doesn't have this feature, so try to change it and that would throw everything all over for a loop, so it was back to square one and reset everything to even have a small chance to have it all work again. Full disclosure here, I am suspecting that the fact that my motor was a later version without hall sensors, and having to run the frankenrunner in sensorless might have a lot to do with the lack of performance, and am trying to find a hall PCB for this motor, because they used to make them with halls, but so far am having a hard time in that search. But will eventually find one that works and report back of my findings after that is tested. To get some sense of perspective, I have a BBSHD and also the G510, and the BBSHD paired with a Kelly 30 or 40 amp controller is crazy, that bbshd seems to have gobs more torque and this simply shouldn't be the case

Long story short I took out the CA3 and plopped in on my desk, and wired up just a throttle to the Frankenrunner. Test ride had me grinning from ear to ear, even though it wasn't throwing the front wheel up like I had been told by numerous people, it was leaps and bounds better than with the CA3, which in itself had me quite perplexed seeing as how I just assumed they would work seamlessly with one another without any of this headache I was experiencing. This, in my experience is far from the case, and I thought to myself a few times, maybe I was just one of the few unlucky people to get a Phaserunner during the crazy covid times, when they didn't have the phaserunner, only the frankenrunner(Its very clearly different in more ways than they are leading on) but while touting its the same device internally, or maybe it was just that I got a super finicky specimen in the silicone lottery...I am unsure at this point, but what I do know is, I will absolutely by all means possible avoid Grins customer service, this unfortunately for me means I would not buy any more products but REALLY wish they had up to par software for my existing hardware. How hard is it to make a set of default values that change EVERYTHING. like a factory reset? Why don't the default profiles you download from grins website change ALL settings back to a set baseline? Cause they don't. Even though you'd be in the right to believe they did. Its just how its supposed to work, there is not supposed to be settings behind the scenes that stay when factory resetting something. I guess maybe that's why they don't specifically state that its a factory reset. Either way, its dumb and needs to be revamped. Maybe a separate suite of software for different products is needed? I don't know, but I am knot paid to know either, just here to throw my money at them and get sub par support and supporting software back lol. By the way, I am mainly referring to the phaserunner suite here, when I say the default settings don't actually reset all settings. The ca3 software I haven't had any issues ,like that, at least none that stuck out like the PR suite.

All in all, I am severely underwhelmed by the hardware, it should by all rights be better and I think that its wings are being clipped somehow in the software behind it all. This totally tracks with what you're now saying, about the old software being superior. wish I had been a little bit sooner to buy than I was. Seems to me after reading around about ASI, is that software is a massive problem all over, from locking software down unless you bought the product directly from them, to just plain old underdeveloped programs in Grins case. I see the absolutely massive potential in the hardware, just hope the other side of things can give their heads a shake and put a little bit of resources into the development to support it I think is what's needed I think..

Disclaimer. I am not any sort of expert of anything I am talking about in this response, I have just come to these conclusions on my own accord after dealing with a very frustrating experience for about a year no and spending countless hours combing message boards and watching videos on specific pieces of hardware and figured it lined up and is relatable with what OP was saying so am just airing my experiences and opinions, I am just a hobbyist at the end of the day, but I know what I know in terms of what's happening in front of me, and somethings not adding up along the lines somewhere.

I apologize if this is hard to read or jumped around in places, I am at work while writing this and because of that I have been interrupted multiple times, some for long periods so it could translate into repetition or jumping all over haha, again, I apologize.

/rant off
I don't, personally, like the Phaserunner suite either. A lot of things I want to simply turn off, like max voltage limit when it's tripping incorrectly, and regen when I'm using a battery combiner or DC converter, can't be turned off, for example. Setting a higher battery amps or voltage limit than spec'ed just undoes your work. Other settings change each other, like the motor power ones. And that's with the Mac app, which does have the ability to set all the defaults.

The Android app is annoying in that it is missing several settings. It took me weeks to learn to flash a clean rom/set defaults, load default parameters, auto-tune, then just tweak the one or two very basic settings I need to have a functional setup. Also to prefer doing anything possible on the CycleAnalyst side and not controller side. Otherwise it was easy to get non-working settings.

Anyway, there are extenuating circumstances at least. Grin has said ASI controllers simply don't support completely disabling regen, for example. The device firmware for the CycleAnalyst has been said to be hampered by already being the max size for the device and needing to be written in 8-bit assembly or something like that. So they can't actually add new features or PAS algorithms. The controller firmware could be similar.

I did see warnings about the Android app being more beta than production ready. Also, I saw in the manual, Grin does not recommend changing base system voltage and multipliers, even when attaching a different voltage battery. So some of your problems are due to not following the manual.

Lastly, the official software for ASI controllers sounds even worse. Like you need a username and password and ASI monitors use and disables it if too many use it. It sounds like ASI made the decision that their software should be vendor/integrator/factory only, not for end users. That may suck for us end users who want to tweak things, but it's a valid business decision. It takes a lot more software engineer people hours to make software usable by end users.
Not sure it'll help, but here how I have my PR's setup. I have two gmac bikes, each has done over 4,000km.

PR 1st screen:




3rd screen is only stats, but for completeness:


Acceleration is good with phase current at 80A. I get up to 1.5kw regen depending on the speed. The only problem with regen is if I'm going down a very steep hill fairly slowly. At a certain point while slowing down it seems like the PR loses sync and starts to sound growly / rough. I think this is when the PR transitions from sensorless regen to sensored regen. If not on a steep hill and just using regen to slow down hard on mostly level, there's no issue. Must be specific to an increase in regen phase current because of the hill.