• Howdy! we're looking for donations to finish custom knowledgebase software for this forum. Please see our Funding drive thread

Bafang mystery

Skteam

1 µW
Joined
Oct 13, 2021
Messages
3
Hi all. I recently bought a used cargo bike here in San Francisco with a bafang mid-drive already installed. It is this unit:

https://bafangusadirect.com/products/complete-bafang-750w-bbs02-mid-drive-ebike-motor-kit-battery

After a few rides, the assist stopped providing power to the crank. The LCD turns on and stays on, and all of the functions on the LCD work fine. However, there is no assist power from the drive. When I press the throttle, I hear a very quiet click from the mid drive (once each press) and occasionally a very brief and quiet spinning sound (these sounds are so quiet you could never hear them while riding—only in the garage). I used a multimeter on the battery output cord, and it reads 52V.

I’m mechanically inclined but don’t have experience with ebike units and am not sure how to troubleshoot further. Any thoughts or ideas as to the best next steps for troubleshooting would be greatly appreciated.

Thanks,

Kyle
 
E-HP said:
Did it stop providing assist while you were riding it, or something that happened after a ride?

It was after a ride. I plugged it in to charge for a couple hours after a ride and then the problem arose when I tried to ride it again the same day.
 
Difficult to say..could be a myriad of possible causes. when you plugged it in, was there a short or a spark? I'd at the very least try to disconnect and reconnect all the plugs, check for loose connections. If you can get a programming cable, maybe check the settings. There's a lot of info online on it. there's a way to jumper the display wires to try and diagnose the problem. Did you happen to wash the bike before or after charging? Sometimes water ingress at the motor/controller can cause this. Usually the controller is the culprit when the motor doesn't turn on, it is not a difficult repair and costs around $85-$100. I'd try to diagnose it further before
replacing the controller. Good Luck!
 
Thanks for reply. There is not a spark when I plug in the charger, but there was/is a spark when if I unplug the battery from the bike and plug it back in. I did this in between the last time it worked and when it stopped working. It think I should probably buy a new controller and see what happens.
 
Back
Top