• Howdy! we're looking for donations to finish custom knowledgebase software for this forum. Please see our Funding drive thread

Cannot get KT controller to work with scooter - please help

Joined
Oct 17, 2022
Messages
10
This is a continuation of my previous post, where order a KT36/48SVPRK-SLS02G controller and couldn’t get it working on my scooter. Ends up I received a faulty controller. So, I have no received a replacement that seems better than the 1st one but I cannot get it to work with my setup either.

I have a 3-wheel mobility type scooter with a 750-watt 48-volt direct drive brushless motor (front wheel). It had a generic controller with reverse and no display. Link to old controller https://www.amazon.ca/Motor-Brushless-C ... 174&sr=1-3

I wanted to upgrade to a better controller with a display so I bought a new KT36/48SVPRK-SLS02G controller with a KT-LCD8H display. Link to new controller https://www.amazon.ca/Brushless-Control ... 142&sr=8-1

Everything will work with the old controller, so motor and throttle are fine.

I have hooked up only the basic connections needed. Power, throttle, motor wires, 6-wire phase connector (no signal wire, white wire), electric lock - jumpered, have tried with and without the display (display plug bypassed without the display) and get nothing. Motor doesn't spin or even try to start.

When using the display, the display does turn on. The display shows 52 volts battery voltage. When the throttle is turned “Throttle” comes on above speed display. I have 52 volts at power connector, 52 volts at electric lock connector (jumpered 52 volts on both terminals). I get 5 volts on red and black terminals on throttle connector and between negative and the signal wire I get from .8V to 3.4V as the throttle is turned. I also get 5V from the black to each hall wire (green, blue and yellow) on the 6-wire connector. And obviously no output on the phase wires. Again, everything works if I put the old controller back on.
Other thing I have tried is turning on “Walk Mode” this gives a “Motor Position fault sensor!” error on the display. Anyone know what this is? Tried a google search and not sure if this is referring to the hall sensors or would it be because of not having a speed sensor in the motor?

I have attached a picture of the settings on my controller. Can anyone see if any of these are wrong? Or does anyone have any extra troubleshooting tips or ideas of what may be wrong? Can’t believe I would have received another faulty controller, but am at a loss.
 

Attachments

  • 20221110_151724.jpg
    20221110_151724.jpg
    2.1 MB · Views: 148
They simplified the error report on the LCD8. There are only two errors and neither tell you much. An error during walk mode would say the the Halls and phases are not wired right, You wired by color? KT controllers generally use a common standard with most motor. You should be getting a similar error on throttle.

Do you have the display set for PAS 1 or higher when you invoke throttle? With your C4 setting, throttle response is inhibited if PAS 0 is selected. Throttle will still work, but no motor response. Try PAS 1. Should get same errot as Walk mode.

Seems to me that your mobility device motor uses a a different color scheme on the three phases and five Hall wires. The speed sensor doesn't matter at this point,

There's a flow chart people follow that avoids having to go thru the 36 possible combinations of the Hall and phase wires. I don't have it handy. Maybe someone else will post it.

But before you do that, put your volmeter red probe on a Hall signal wire, with the controller powered up. B;ack one on ground of course. Rotate the wheel backwards, which will spin the motor and flip the Hall sensors. Check to see if all three signal lines go up and down as the motor turns. I suggest backwards because I don't know if you have a geared or non geared motor. If it's non geared, you can rotate either direction to see the Hall sensors flip. but a geared motor only does it backwards. That will at least tell you if the motor has Hall sensors.
.
 
Thanks very much for your help.

Just need to clarify. This is a 3 wheel mobility type scooter so no pedaling, just throttle and motor is a non-geared direct drive hub motor. With multimeter hooked up to hall wires signal does rise and fall. Right now I have phase and hall wires hooked up by color.

If the phase or hall wires are mismatched would the motor not try and at least run? Jerk or run backwards? Also, will there not be voltage on the phase wires (between phases, so yellow to green or yellow to blue). Not sure if I have a complete understanding of all of this, so I could be wrong.

I will get to work and try and find flow chart and try all phase and hall combinations and I will go through settings on display and try and change PAS settings. I assumed if you are not using PAS sensor that setting would be 0, I will try other value.
 
So tried changing the PAS setting to 1 - 5, and yes now I get "Motor position sensor fault" when operating the throttle or in Walk Mode. So does this probably mean phase and hall wires are incorrect?

Tried changing just phase wire combinations but no change, no jerking or trying to run. I will try more searching for wiring flow chart. Is this the correct one?https://i.redd.it/hcv0h1poxqk61.jpg
 
If that is the correct flow chart, I have tried following through it and nothing changes. Motor does not try to start and no voltage on phase wires.

???
 
It seems likeliest that you have either a continuity problem in a plug or wire, or you have a bad Hall sensor.

The other option, less likely, is that you have a bad controller or display.
 
ScooterBill said:
Everything will work with the old controller, so motor and throttle are fine.

Can you provide a pic of the label on the original controller?

If your old controller defaults to sensorless operation when there is a hall sensor issue, then it could run just fine and you might not know it, even though the motor is not "fine". You could test your old controller by disconnecting the hall sensor plug and see if it still works. If it does, you'll need to do some more diagnosis on your motor.
 
Thanks docw009, Chalo, and E-HP, you are all the greatest.

I had no idea a hub motor could work without the hall sensors working. The motor worked with the old controller so I never even suspected the motor, so I never checked it. Ends up the positive, red wire is broken so I will get that fixed and I'm pretty sure it will work.

I learnt a lot with the help of the great members of this forum. Always a good day when you can learn something new.

Thanks again for all of your help.

ScooterBill :D
 
Back
Top