Stuck - Upgrading Battery from 36V to 48V on Ecotric Rocket


1 µW
Nov 25, 2023
Tampa, FL, United States
Hi All, After a lot of reading and attempts, Im stuck trying to upgrade my Ecotric Rocket ebike from its original 36V 12.5ah Battery to a new expanded 48V 20ah battery. I have tried a lot. Here is the history.

I have an Ecotric C-ROC26S900-BL that I have had for 2.5 years (36V, 12.5ah, 500W motor). The controller that is in it is LCO3622C1H-TS23. It has the Ecotric branded S900 LCD. It has run great for me. I ride it roughly 2 - 3 times a week. I have 1000 miles on it.

The Battery started dying. Bike would run slower at speed settings below 5 (But would run at 20MPH at setting 5) and would run out of power before I finish my ride. So I considered buying a new bike vs. upgrading the battery. I love the bike, am very DIY handy, so I thought I would upgrade the battery. I wanted to add more speed and a longer run time, so after a lot of reading, I decided to go with a 48V 20ah battery. Through my reading, I also discovered that I would 'probably need to replace the controller" but that was not completely clear. So I purchased the battery and a 48V Ecotric controller model LCO4822COD-TS26 (I think this is a controller for Ecotric Seagull). I thought the existing LCD would work because its setting enabled my to switch it up to 48V.

I installed the battery first without any problems. Set the S900 to 48V. As I thought might happen, my S900 gave me an Error 9 - High Power. So I assumed I needed replace the controller. I replaced the controller with the 48V version I bought and I thought everything was good. Error 9 went away, no error shown. Everything works (throttle spins the wheel, brakes shut of motor, etc.).

The problem I have is that the S900 Speedometer does not seem to be reading correctly (shows me traveling at 20mph when I am only going 10mph) and thus I am only able to get about 10mph out of the bike at any setting. The controller thinks I am going much faster than I actually am. I checked all the settings for wheel size. max speed, etc., all looked correct and even if I change them, it does not seem to impact it significantly.

Here is the other interesting fact. The S900 LCD that came with my bike only had 12 settings (when you hold down he up/down arrows to get into settings). Where as other S900's have 16 settings and give you the ability to set the number of wheel magnets. The one I had did not provide an option to set the number of wheel magnets.

I thought maybe I needed a newer version of the S900, so I bought what was listed as the 48V version of the s900. The new LCD arrived, I installed it, and it gives me an Error 10 (communication error). It does have the expanded settings but does not work with error 10 displayed. When I go back to my original S900, the error 10 goes away. So I know I have communication happening. I also tried jumping the yellow and green wires to opposite without resolution.

I really don't believe the s900 is the problem. My current thinking is either the new controller I bought is faulty or it is just not compatible with my Motor.

I am hoping you may have some ideas about next steps or how I could fix this problem.

Buy a new controller and display unit as a matched pair for your new 48v generic battery.
Keep the amps the same and keep track, if it gets too hot, then limit the amps.
Former Ecotric owner. I've read on the ecotric facebook forum that S900's from different models are not compatible. .

I'm sorry that you spent a lot of time and expense upgrading to no avail, but you may have to do what calab suggests. Buy a A new controller/display as a matched set, Personally, I think S900's have a crude PAS response. I prefer KT controllers, but their connectors are all reversed from what Ecotric uses, so it;s a major switch.

Usually the controllers and displays are "matched sets", because either can have firmware that is incompatible with the other, even if they are the "same" brand / model.'ll probably need to order the set of controller plus display that does what you want with the features you want. Or if you already know for sure the controller does what you want, and has a display available from the same place that is intended for it that you also know does what you want, get that display.

You may get lucky and have some other combination work, but the "certain" way is the above. ;)

There may be another way to solve the problem, using the new controller and original display, see below.

The comm error usually means that there is a connection fault or that the firmware is so different that they can't understand each other. (or rather, the display can't hear or understand the controller; you can't know if the controller hears or understands the display as there's no interface to show you).

The lack of display menu options for specific features on one version vs another means the OEM ordered them that way for whatever reason.

If the motor worked with the controller, it's not incompatible with it.

The speedo problem is probably caused by the settings that you don't presently have access to as you note. Does the controller have a separate speed sensor wire available? Usually this is white, within the hall sensor / phase wire motor connector bundle.

If it's a geared hubmotor, this is almost certainly the case. If so, inside the hubmotor there is a separate sensor that reads a set of magnets inside the hub casing. There are almost always six holes for magnets. If they used six magnets, four, or two, you can take half of them out and the speed will now read correctly. If they used 3, 5, or 1, that won't work.

But you *can* build a small circuit that goes on the separate speed sensor wire to divide the number of pulses by two. (this won't work unless it *is* a separate speedo signal wire).
Thanks to all for your great insight. I am able to get an S900 model from Ecotric that is specifically matched to the Controller I have. So I have ordered it and am going to go that route. I am also able to return the other S900 I bought, I will let you know the outcome of buying the matched S900.