Xenforo conversion thread

neptronix

Administrator
Staff member
Joined
Jun 15, 2010
Messages
17,989
Location
Utah, USA
Howdy folks!
Doing the Xenforo conversion today!

It's 9:25am over here in mountain standard time as of writing.
You can expect a few minutes of downtime here and there in the coming hours as i'm 'swapping wires' :)

I expect to get started in 1.5-2 hours from now. I will give a 30 min warning before i hit the big red button.

Heads up: during the conversion, the forum will either be totally unavailable or in read only mode.

More to come.
 
Forum backup is finished, prepping for the surgery. Feel free to post while i work.
 
Prep mostly done, i'm thinking i'll be operating in about 30 min.
 
Allright my dudes, ready to let it rip!

You have t minus 15 minutes to wrap up business before i hit the big red button.
 
Okay!
It's 8pm over here and i'm about to hang up my hat but i'll check in after dinner if anything is going on that shouldn't be!

If for any reason you are having issues logging into this new forum because your username got bodged ( something we thought we finally won against but aren't 100% sure)..
Visit the graveyard: https://endless-sphere.com/forums-old
And send me ( neptronix ) a PM and i'll look into it.

The graveyard will be active for another week just so you can bug me if somethings' wrong.
Then it will go to disabled ( won't allow new posts ) afterwards and will be kept for a while for reference on anything lost in this conversion.
Otherwise it appears URLs against /forums are successfully redirecting to /sphere.

If anything else is very, very screwed up, please let me know.
I'll be here for ES tomorrow to do triage, restore the old smilies, and put on some finishing touches (y)
 
Main problem I see so far is I don't appear to have any moderator controls/etc visible?

It does say I'm a moderator if I click my username at the top bar, righthand side. I do have access to the moderator forums, but not any of the controls, at the top of the page or on any posts.
 
Last edited:
Apologies for possibly retreading previously discussed things, as I'm so tired (beyond exhausted, but can't sleep) that I have already forgotten if this was covered, but it doesn't appear to have imported followed and ignored memberlists in my profile.
 
Uh oh

Let me fiddle with the knobs!
 

Attachments

  • 2023-02-15 21_06_30-Screen_Shot_2018-10-25_at_11.02.15_AM.png (1354×784).jpg
    2023-02-15 21_06_30-Screen_Shot_2018-10-25_at_11.02.15_AM.png (1354×784).jpg
    7.5 KB · Views: 2
Amberwolf, did i fix it for you?

..if not, i think it's complicated; sorry and i will beat on xenforo tomorrow.
 
I don't see anything different. I logged out and back in to see if that would do it, and also on a different browser (both my ancient firefox and the latest chrome)

Another conversion issue that could have been discussed and I just forgot; it doesn't seem to have linkified URLs such as the ones here
and others generally; numerous examples on that page:

Other posts in teh same thread where I had used PHPBB URL tags it does seem to have correctly done the job.
 
I also can't see some user's profiles (seems to be limited to banned members?); I get

"Oops! We ran into some problems.
This user's profile is not available."

Others I can see just fine (like yours)

If it is a banned member thing, that's a poor functionality limitation. People should still be able to look at banned member profiles because they may wish to find their posts for something that was useful in some way, or some media they posted, or other info, etc.
 
Click : new posts
over the first post in the list there is a green button : show only unread

But I think this filter is always on
 
Okay! It's 8pm over here and i'm about to hang up my hat
Congratulation mate, the forum looks a lot better and it's much easier to use!
Thanks for the great work
 
Looks like things are generally working!
All of my watched threads are intact and I see new post notifications.
Links on duckduckgo search resolve to the appropriate pages.
Awesome work neptronix and team!
 
Looks awesome!
Thanks Admin team.

Issues:
1. embedded URLs are how clickable (??), scratch this issue, I think the author post was the issue.
 
I miss the specific view counter on the threads. It was fun to watch the 40-50- hits a day on new posts. Now it just shows 3k views. I won't see anything until 4K ? How will I know if the thread is dead? It's really the only incentive I had to keep the thread up to date.
 
It's so nice to be able to reply and not have to sort quotes and code. However simple that code was I found it frustrating. Nice!
 
Click : new posts
over the first post in the list there is a green button : show only unread

But I think this filter is always on
You mean "New posts" in the upper, left corner?
Then I see all new posts in the forum. I want to see which threads there are unread replys in, in the topic I am in at the moment.
 
Howdy folks.
I'm very very very happy we made it through the night and nothing went kaboom. :eek:
Thank you for your support, i'm SO relieved the nerve wracking process is done :)

From the server side, i can tell Xenforo is efficient AF and the average load on the forum today is just 1-2%, compared to PHPBB having a >50% average load on the same configuration. I'm very impressed with this!

Glancing over the feedback -
I agree that there are some things in phpbb we could use back.
..there are also some very cool Xenforo features that we don't have set up like the stack-overflow like questions / answers format!

I imagine that everyone is sort of in the middle of a learning curve since last night so i am going to avoid making very big changes today because they may interrupt the forum and we've already got enough variables in the air today.

I will be playing with the knobs today seeing what i can address and also doing some work on the server to downsize it so i can save Grin some $ on the hosting bill.
Expect some possibly weird behavior today and a few min server outage sometime in the next hour or so!
 
Back
Top